Back to overview
Resolved
Perfromance issues
Oct 30, 2025 at 7:26am UTC
Affected services
Applications and VPNs
Resolved
Oct 30, 2025 at 7:26am UTC
we are seeing unusual performance on the server and are investigating
Affected services